Delay sending emails to surgeries via NHS email in Titan
Incident Report for Titan PMR
Resolved
Customers still using SMTP please follow these instructions
https://invatechhealth.com/nhsmailtitan.pdf
Posted Jun 30, 2023 - 07:41 UTC
Update
EWS access has been restored, so NHS emails are working again as normal without the need for you to make any changes.

Work will continue over the coming days to introduce a new Auth process for NHS emails, and we will be in touch to advise on the steps you will need to follow to ensure continuity of service after 30th June 2023.
Posted May 31, 2023 - 08:53 UTC
Update
We have been working with the NHS and our internal teams overnight and can provide the following update:

1. The NHS will restore access to the Exchange Web Services (EWS) for sites affected - we will update when this is complete, hopefully at some point today. This will be a temporary arrangement until 30th June 2023.

2. We have introduced a new update to your email history in Titan to indicate whether the GP surgery email has been sent successfully or failed.

3. We are introducing a new OAuth mechanism for outbound emails which will protect against this in the future and we are testing this currently.

4. We provided the NHS link which explains what is needed to set up an application account. It is important that you set this up with the NHS before the end of June 2023.

We will be in touch with an update with (1) is complete.
Posted May 31, 2023 - 08:17 UTC
Update
After discussing this issue with the NHS, it appears that the Exchange Web Services method has been disabled by the NHS over the weekend.

We have introduced the SMTP secondary method for sending email, but for this to work you will need to contact the NHS mail team to get an application account set up, and then mail will work in Titan.

We are working now on a new method of connectivity that does work with the NHS, but this requires an upgrade to the Titan outbound mail service. This work is underway and we will communicate here when it is available.

For now our advice is to contact NHS mail (https://support.nhs.net/knowledge-base/application-account/) to set up an application account, and input this info into Titan and then outbound emails will work.

Apologies for the inconvenience. We will provide updates here as we receive them.
Posted May 30, 2023 - 15:42 UTC
Update
We have implemented a secondary method to send NHS emails on behalf of your pharmacy NHS email account, however this method requires that you've set up your pharmacy email account to have "application account" access.

Unfortunately we will need you to do this yourself as this is something we cannot do. Please follow these instructions to enable application account access https://support.nhs.net/knowledge-base/application-account/

When done, please attempt to send a test email via Titan and it should work correctly.

We are continuing to work on this as we do not know why the primary method of sending emails no longer works.
Posted May 30, 2023 - 11:59 UTC
Update
We are currently working this as a high priority issue. All emails we are attempting to send on pharmacies' behalf are failing, however we have not made any changes to this process at all.

We are working hard to find a solution to this and will provide an update shortly.

In the meantime, you can now download a list of emails you have attempted to send by date, by visiting the Views > Reports section and selecting "Surgery Emails by Date".

We will provide an update shortly
Posted May 30, 2023 - 11:36 UTC
Identified
We are continuing to investigate reports of NHS emails not going through due to authorisation errors. We are actively investigating this and will provide an update shortly.
Posted May 30, 2023 - 11:12 UTC
Update
We have found that in some cases, automated emails via Titan fail due to a response from the NHS stating "Unauthorised". This is because multi factor authentication has been enabled on the NHS email account.

We advise that this is disabled for the time being, as this will prevent the sending of the emails via an automated system.

We are still gathering information on this and will provide further information shortly.
Posted May 30, 2023 - 10:42 UTC
Monitoring
The backlog of outbound NHS emails is now clear, and this issue has been resolved.

FYI should you still experience an issue, please double check your email and password information and update the Titan marketplace settings if they have changed.

Please contact our support team if you are experiencing an issue and we can support you with the above https://invatechhealth.com/support
Posted May 30, 2023 - 10:17 UTC
Identified
This morning there is a backlog of outbound emails that go to GP surgeries from Titan via your NHS email account.

This may mean if you have sent email medication orders from Titan this morning, they won't immediately appear in your NHS email sent items. The backlog is being sent currently so should complete within the next hour.

We will provide a further update shortly when the backlog is clear.
Posted May 30, 2023 - 09:23 UTC
This incident affected: Titan access to NHS.