NHS EPS downloads for Pod 3 customers
Incident Report for Titan PMR
Resolved
After a period of monitoring this incident is now resolved.

Our secondary data centre experienced a brief outage earlier which had a knock on effect of impacting the NHS spine message handler in use for some Pod 3 customers. The incident has been resolved and preventive work is underway to avoid a future occurrence.

Apologies if you were impacted by this in any way.
Posted May 25, 2023 - 15:06 UTC
Update
We have isolated the cause and have introduced a resolution. We are rebooting all affected sites' NHS spine message handler service which should result in a return to normal operation. If you are affected, and still experience issues from 13:15 onwards, please restart Titan on your PC and try again.

Should you still experience any issues please contact our service desk immediately.
Posted May 25, 2023 - 12:06 UTC
Identified
We have identified an issue that is affecting some Titan customers who reside on Pod 3, where EPS downloads are timing out. We have engineers working on the issue and aim to have it resolved very soon.

We will provide an update here shortly
Posted May 25, 2023 - 11:47 UTC
This incident affected: Titan access to NHS.