Some users experiencing an issue following a recent update
Incident Report for Titan PMR
Resolved
Issue was resolved earlier this morning by applying a hotfix to affected sites which was successful. Apologies for anyone who experienced inconvenience.
Posted Jan 07, 2022 - 11:55 UTC
Identified
We are aware of an issue with some users who upgraded to the latest version of Titan overnight, in particular relating to Power Search. This issue is identified and an update is being deployed currently. If you are affected then you will find this issue is resolved automatically very soon.

Apologies for any inconvenience caused.
Posted Jan 07, 2022 - 09:19 UTC
This incident affected: Titan core API platform.