Titan connectivity
Incident Report for Titan PMR
Resolved
This incident is resolved after a period of monitoring. Apologies for any inconvenience this may have caused.
Posted Mar 15, 2023 - 11:29 UTC
Monitoring
We have applied a fix to this incident and we are seeing connectivity returning. If you were affected please close and reopen Titan now and you should be operational again. If not please contact support via support@titanpmr.com. We will continue to monitor the situation.
Posted Mar 15, 2023 - 10:17 UTC
Identified
We have identified the issue and it is affecting any customers who reside on Pod 3. We have engineers working on the problem now as a P1 incident. We will provide an update shortly
Posted Mar 15, 2023 - 10:10 UTC
Investigating
We are investigating reports of some sites unable to connect to Titan. We are investigating currently.

If you are experiencing a connectivity issue please contact our support desk via support@titanpmr.com
Posted Mar 15, 2023 - 10:03 UTC
This incident affected: Titan core API platform.