Titan HSCN issue
Incident Report for Titan PMR
Resolved
Redcentric have resolved the incident and we have received this update. Services returned at approximately 4.45pm.

"Please be advised; following our previous update, we have seen services restore. Testing has been carried out with impacted customers, which has confirmed restoration. We shall now enter an extended period of monitoring to ensure services remain stable. A further update shall be made available tomorrow. "

Apologies if you were impacted by this incident.
Posted Dec 14, 2023 - 20:27 UTC
Monitoring
We are seeing HSCN services restore from 16:45 onwards.
We are continuing to monitor the situation and will provide another update shortly.
Posted Dec 14, 2023 - 16:48 UTC
Update
Redcentric have a nationwide network connectivity incident affecting our access to HSCN.
We are working with them to urgently deliver a resolution and will keep you informed.
Posted Dec 14, 2023 - 16:20 UTC
Investigating
We are investigating reports that customers are unable to access Titan via HSCN.
This is a P1 issue and we have engineers investigating currently. We will provide an update shortly.
Posted Dec 14, 2023 - 16:14 UTC
This incident affected: Titan core API platform.