Titan HSCN issue
Incident Report for Titan PMR
Resolved
We have had confirmation from Redcentric that there was a nationwide HSCN incident this afternoon which caused this issue affecting EPS customers using Titan.

"Please be advised; we are aware of an issue that briefly impacted connectivity for multiple customers this afternoon. At this stage, we do not know what caused this, but have our engineering teams engaged and investigating.

While these investigations are carried out, we shall enter a period of overnight monitoring and a further update shall be issued tomorrow."

When we have a full update we will issue a post mortem with regards to this incident. Apologies to anyone affected and for the inconvenience caused.
Posted Dec 13, 2023 - 19:39 UTC
Monitoring
We are seeing services return to normal from 15:33 onwards. We are continuing to monitor the situation whilst we liaise with Redcentric to understand the cause.
Posted Dec 13, 2023 - 15:43 UTC
Identified
We have identified a core HSCN issue and we are working with Redcentric to help facilitate a resolution to this incident. We will keep you updated when we know more.
Posted Dec 13, 2023 - 15:28 UTC
Update
We are continuing to investigate this issue.
Posted Dec 13, 2023 - 15:22 UTC
Update
We are investigating HSCN connectivity issues resulting in a number of NHS spine services currently unavailable.

This is a P1 issue and we have engineers investigating currently. We will provide an update shortly.
Posted Dec 13, 2023 - 15:19 UTC
Investigating
We are investigating reports that some customers are unable to access Titan via HSCN. We are investigating now and will provide an update shortly
Posted Dec 13, 2023 - 15:06 UTC
This incident affected: Titan core API platform.