Pod 2 performance
Incident Report for Titan PMR
Resolved
Emergency maintenance work has been completed successfully and as such, the incident from earlier today has been resolved.

Our team will continue to monitor closely over the coming days but services are confirmed as operating normally.

Apologies for any inconvenience caused if you were affected by this issue.
Posted Dec 12, 2023 - 21:43 UTC
Update
Emergency maintenance will take place between 9-10pm tonight on Pod 2.
Customers may still use Titan during these hours, however may experience some brief moments of connectivity lapses.
Posted Dec 12, 2023 - 17:06 UTC
Monitoring
The system has stabilised and our engineers will continue to monitor the situation closely.
Posted Dec 12, 2023 - 12:39 UTC
Update
We are continuing to investigate this issue and have seen some improvement to performance.
We are still working on this and will provide an update shortly, our apologies for any inconvenience caused to those affected.
Posted Dec 12, 2023 - 12:12 UTC
Investigating
We are currently investigating performance issues on Pod 2.
Posted Dec 12, 2023 - 11:55 UTC
This incident affected: Titan core API platform.