Performance issue impacting Pod 4 customers
Incident Report for Titan PMR
Resolved
After close monitoring this Incident is now resolved and all services are operating normally.
Posted Sep 08, 2023 - 11:35 UTC
Monitoring
We have seen recovery from the earlier incident and systems are operating normally. We will remain in a period of close monitoring
Posted Sep 08, 2023 - 10:32 UTC
Identified
We have identified an issue and can now see improvements.

If you experienced an issue please close and reopen Titan and it will then return to normal.
Posted Sep 08, 2023 - 10:29 UTC
Investigating
We are currently investigating an temporary performance issue impacting customers on Pod 4. We are working to resolve this issue and will provide an update shortly.
Posted Sep 08, 2023 - 10:18 UTC
This incident affected: Titan core API platform.