Titan outage affecting some sites
Incident Report for Titan PMR
Resolved
The core issue has been resolved by Daisy and we will continue to monitor closely.

Apologies for any inconvenience this caused this morning.
Posted Nov 26, 2020 - 10:45 UTC
Monitoring
We are seeing a return to services now and continuing to work with Daisy on the issue.

You may see connectivity restored and Titan fully operational again. We are monitoring currently.
Posted Nov 26, 2020 - 09:00 UTC
Update
Customers with VPN access can still access Titan, and HSCN customers should switch to this method of connecting to Titan for the time being.

If you need some support setting up a VPN on a client PC connected to an internet connection in your pharmacy, please contact support@titanpmr.com
Posted Nov 26, 2020 - 08:01 UTC
Update
We've had an update from our third party provider which suggests the connectivity issues relate to some overnight maintenance work they carried out, and are attempting to diagnose the problem now.
Posted Nov 26, 2020 - 07:50 UTC
Identified
We appear to be experiencing a core DNS issue which is causing HSCN connectivity issues to some of our customers but not all. We are working with the third party and aim to have this resolved as soon as possible.
Posted Nov 26, 2020 - 07:08 UTC
Investigating
We are currently investigating an outage affecting some Titan sites with connectivity. We will provide an update when we have more information.
Posted Nov 26, 2020 - 06:47 UTC