Titan performance issues
Incident Report for Titan PMR
Resolved
The issue is confirmed as resolved although emergency maintenance will take place this Sunday evening and a separate notification will be sent in relation to this.
Posted Nov 25, 2022 - 12:50 UTC
Update
The issue appears to have related to a spike in activity we received on our core VPN firewalls at around 9.30-10am this morning.

We are in the process of arranging some emergency platform upgrade maintenance for this Sunday (comms will follow shortly).

In the meantime customers using VPN to connect to Titan should be able to operate normally but will see a further benefit following Sundays maintenance.

Will provide a further update shortly
Posted Nov 25, 2022 - 11:40 UTC
Monitoring
We are continuing to investigate and have seen improvement across some of the affected sites. We are continuing to monitor please do contact us if you are still experiencing performance issues. We will provide an update shortly.
Posted Nov 25, 2022 - 10:29 UTC
Investigating
We are currently investigating reports of sub-optimal performance for some customers. We are aware and investigating the issue now and will provide an update shortly.
Posted Nov 25, 2022 - 09:59 UTC
This incident affected: Titan core API platform.