Mass IT outage - Titan unaffected
Incident Report for Titan PMR
Resolved
This incident has been resolved.
Posted Jul 21, 2024 - 19:50 UTC
Monitoring
We are sure you are probably already aware of the current IT issues that are impacting services around the globe currently.

This message is to let you know that Titan is not affected and all systems are operating normally.

We understand that Emis (amongst others) are affected and this will impact the generation of EPS prescriptions, so you may see an impact to prescription arrivals today.

We are continuing to monitor the situation.
Posted Jul 19, 2024 - 08:49 UTC