Titan AI - Level 5 outage

Incident Report for Titan PMR

Resolved

After a period of monitoring, this incident is now resolved.

Titan AI - Level 5 customers can now resume using this Level again.

Our apologies for any inconveniences this may have caused.
Posted Aug 25, 2026 - 14:51 UTC

Investigating

We are currently investigating a Titan AI - Level 5 only outage.

The workaround for now, is to switch back to using Level 4, once the issue is identified and resolved we will inform all Level 5 customers, when you can resume using it again.

This will only impact customers who currently have access to Level 5.
If you have any concerns please do contact our service desk.
Posted Aug 25, 2026 - 09:24 UTC
This incident affected: Titan AI.