Pod 17 performance

Incident Report for Titan PMR

Monitoring

A fix has been implemented and we are now in a period of monitoring
Posted Apr 15, 2026 - 12:39 UTC

Investigating

We are investigating reports from some Pod 17 customers being unable to access Titan.
We are investigating this currently and will provide an update shortly.
Posted Apr 15, 2026 - 12:15 UTC
This incident affects: Titan core API platform.