Pod 11 Performance

Incident Report for Titan PMR

Monitoring

A fix has since been implemented and we can now see Pod 11 performance returning to normal.

We are now in a period of monitoring, If you do have any remaining issues please do contact the Titan helpdesk.

Our apologies for any inconveniences caused.
Posted Jul 27, 2026 - 14:47 UTC

Identified

The issue has now been identified and we are now working on implementing a fix.

A further update will be posted once the fix has been implemented.
Posted Jul 27, 2026 - 14:36 UTC

Investigating

We are currently investigating performance issues impacting Pod 11 customers and will provide an update shortly.
Posted Jul 27, 2026 - 13:54 UTC
This incident affects: Titan core API platform.