Titanverse in-app support

Incident Report for Titan PMR

Resolved

The third party provider has confirmed the issue has been resolved.
Posted Jan 05, 2026 - 15:41 UTC

Identified

Our third party service desk provider for Titanverse is currently experiencing an intermittent outage. As a result, whilst using Titanverse you might experience a lack of availability for the in-app help widget.

We will provide an update when we have further information.
Posted Jan 05, 2026 - 14:48 UTC
This incident affected: Titan Helpdesk.