Titanverse
Incident Report for Titan PMR
Resolved
After a period of monitoring the incident is resolved and was restored at 9am today.
Posted Nov 13, 2024 - 11:51 UTC
Monitoring
A fix has been implemented and we are currently monitoring the results.
Posted Nov 13, 2024 - 09:02 UTC
Identified
We have identified an issue with accessing Titanverse from some locations. Engineers are currently working on a fix and we will provide an update shortly.
Posted Nov 13, 2024 - 08:32 UTC
This incident affected: Titanverse Services Platform.