Titanverse in-app support

Incident Report for Titan PMR

Monitoring

The third party provider has confirmed the issue has been resolved and they are now in a period of monitoring
Posted Mar 16, 2026 - 16:39 UTC

Investigating

Our third party service desk provider for Titanverse is currently experiencing an intermittent outage. As a result, whilst using Titanverse you might experience a lack of availability for the in-app help widget.

We will provide an update when we have further information.
Posted Mar 16, 2026 - 16:07 UTC
This incident affects: Titan Helpdesk.