Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 22, 2026 - 20:00 UTC
Scheduled
Emergency third-party maintenance affecting HSCN connectivity will take place from 21:00 on Wednesday 22nd July until 07:00 on Thursday 23rd July.
During this window, Titan will remain fully operational for day-to-day use. HSCN traffic (the connection between Titan and NHS services) may be intermittently affected while the work is carried out.
As a precaution, EPS nominated download requests will be temporarily disabled for the duration of the window to avoid partial or failed transactions during any period of reduced connectivity. This function will be automatically re-enabled by 07:00 on Thursday 23rd July, and normal EPS activity can resume from that time.
We expect no impact to morning dispensing, as connectivity is scheduled to be fully restored well before the start of the working day.
Apologies for any inconvenience this essential maintenance may cause.
Posted Jul 21, 2026 - 13:30 UTC
This scheduled maintenance affects: Titan access to NHS.