Integration APIs

Incident Report for Titan PMR

Resolved

The connectivity incident has been resolved and all services are fully operational.

Apologies for any inconvenience caused if you were affected.
Posted Oct 15, 2025 - 09:28 UTC

Update

Connectivity fully restored. If you continue to experience any issues please contact integrations@titanpmr.com
Posted Oct 15, 2025 - 08:48 UTC

Monitoring

Connectivity is being restored and is coming back for affected services currently.
Posted Oct 15, 2025 - 08:29 UTC

Investigating

We are currently investigating reports from some customers who use our APIs relating to connectivity. If you are experiencing an issue please share technical details with enterprise@titanpmr.com,

We will provide an update shortly.
Posted Oct 15, 2025 - 07:36 UTC
This incident affected: Titan Enterprise API.