Titan VPN connectivity

Incident Report for Titan PMR

Resolved

A&A customers we have spoken to have seen services restore.
Posted Oct 23, 2025 - 11:46 UTC

Monitoring

A&A have made a change as per this incident (https://aastatus.net/42796)

We have seen that sites affected are starting to regain connectivity. If you are affected please attempt to reconnect your Titan VPN.
Posted Oct 23, 2025 - 09:49 UTC

Identified

A&A have acknowledged the issue and they are working on it currently

https://aastatus.net/42796
Posted Oct 23, 2025 - 09:14 UTC

Update

It appears that an Internet Service Provider Andrews & Arnold is experiencing a major outage.
https://aastatus.net/42795

All customers affected use this ISP and as such are affected by their outage.

Whilst A&A manage their outage, we recommend you switch to an alternative connection either HSCN or non-A&A to get back up and running. Our support team can assist with this if required.

We will keep an eye on the situation
Posted Oct 23, 2025 - 08:39 UTC

Investigating

We are investigating a small number of reports from some sites that they are unable to connect to the Titan VPN. If you are affected please contact our support team https://www.titanpmr.com/support for assistance.
Posted Oct 23, 2025 - 08:31 UTC
This incident affected: Titan core API platform.