Titan helpdesk

Incident Report for Titan PMR

Resolved

This incident has been resolved.
Posted May 26, 2026 - 15:42 UTC

Monitoring

Telephone connectivity has since been restored so all helpdesk services are operating as normal.
Posted May 26, 2026 - 12:10 UTC

Identified

We are experiencing issues with call quality that you may experience if calling the Titan helpdesk. All other channels are working normally and a list is available here https://titanpmr.com/support.

You may wish to contact us via email/ whatsapp/ SMS/ in-app tickets for the time being whilst engineers work on restoring our phone service.

NB: This only impacts our helpdesk service and Titan is running normally.
Posted May 26, 2026 - 08:46 UTC
This incident affected: Titan Helpdesk.